RebarBarTypeSetAutoCalcHookLengths Method |
Identifies if the hook lengths of a hook type are automatically calculated for this bar type
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetAutoCalcHookLengths(
ElementId hookId,
bool autoCalculated
)
Public Sub SetAutoCalcHookLengths (
hookId As ElementId,
autoCalculated As Boolean
)
public:
void SetAutoCalcHookLengths(
ElementId^ hookId,
bool autoCalculated
)
member SetAutoCalcHookLengths :
hookId : ElementId *
autoCalculated : bool -> unit
Parameters
- hookId ElementId
-
id of the hook type
- autoCalculated Boolean
-
True if the hook lengths should be automatically calculated, otherwise false
When it is false, default hook length and default hook offset length will be reported
Exceptions
See Also