AnalyticalMemberIsValidSectionTypeId Method |
Checks whether the family symbol id is allowed for
Analytical Member as Section Type property.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool IsValidSectionTypeId(
ElementId familySymbolId
)
Public Function IsValidSectionTypeId (
familySymbolId As ElementId
) As Boolean
public:
bool IsValidSectionTypeId(
ElementId^ familySymbolId
)
member IsValidSectionTypeId :
familySymbolId : ElementId -> bool
Parameters
- familySymbolId ElementId
-
Family symbol id which has to be checked.
Return Value
Boolean
True if %familySymbolId% is invalidElementId; or if it is
the id of a FamilySymbol of category "Structural Framing"
(OST_StructuralFraming) or "Structural Columns" (OST_StructuralColumns)
Returns false otherwise.
Exceptions
See Also