LineLoadSetCurve Method

Sets the curve for the line load.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetCurve(
	Curve curve
)

Parameters

curve  Curve
 
Exceptions
ExceptionCondition
ArgumentException The input curve is not bound. -or- The provided curve is not supported.
ArgumentNullException A non-optional argument was null
InvalidOperationException This LineLoad is not a hosted load. -or- This LineLoad is a constrained load.
Remarks
The curve must be bounded. The curve can be:
  • Line
  • Arc
  • Ellipse
See Also