ThinLinesOptions Class

A utility class containing setting related to the Thin Lines option which affects the display in the UI.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.UIThinLinesOptions

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ThinLinesOptions : IDisposable

The ThinLinesOptions type exposes the following members.

Properties
 NameDescription
Public propertyStatic memberAreThinLinesEnabled A static property defining if the 'Thin Lines' setting is on or off in current Revit Application Session.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the ThinLinesOptions
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also