ImageTypeOptionsSourceType Property |
Indicates whether the image type is a link or an import.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ImageTypeSource SourceType { get; set; }
Public Property SourceType As ImageTypeSource
Get
Set
public:
property ImageTypeSource SourceType {
ImageTypeSource get ();
void set (ImageTypeSource value);
}
member SourceType : ImageTypeSource with get, set
Property Value
ImageTypeSource
ExceptionsException | Condition |
---|
ArgumentException |
When setting this property: The ImageType source is not correct. Only Link or Import values are allowed.
|
ArgumentOutOfRangeException |
When setting this property: A value passed for an enumeration argument is not a member of that enumeration
|
Remarks
Use this property with the method ImageType::Create to create a linked image type.
Use this property with the method ImageType::ReloadFrom to convert an import image type to a link and vice versa.
Valid values are 'Import' and 'Link'.
See Also