LevelGetNearestLevelId(Document, Double) Method |
Returns id of the Level which is closest to the specified elevation.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static ElementId GetNearestLevelId(
Document document,
double elevation
)
Public Shared Function GetNearestLevelId (
document As Document,
elevation As Double
) As ElementId
public:
static ElementId^ GetNearestLevelId(
Document^ document,
double elevation
)
static member GetNearestLevelId :
document : Document *
elevation : float -> ElementId
Parameters
- document Document
-
The document.
- elevation Double
-
Target Elevation.
Return Value
ElementId
Exceptions
Remarks
The level can be at, above or below the target elevation.
If there is more than one Level at the same distance from the elevation, the Level with the lowest Id will be returned.
See Also