TaskDialogShow(String, String, TaskDialogCommonButtons) Method |
Shows a task dialog with title, main instruction and common buttons.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static TaskDialogResult Show(
string title,
string mainInstruction,
TaskDialogCommonButtons buttons
)
Public Shared Function Show (
title As String,
mainInstruction As String,
buttons As TaskDialogCommonButtons
) As TaskDialogResult
public:
static TaskDialogResult Show(
String^ title,
String^ mainInstruction,
TaskDialogCommonButtons buttons
)
static member Show :
title : string *
mainInstruction : string *
buttons : TaskDialogCommonButtons -> TaskDialogResult
Parameters
- title String
- The title of the task dialog.
- mainInstruction String
- The main instruction of the task dialog.
- buttons TaskDialogCommonButtons
- The common buttons to be shown the task dialog.
Return Value
TaskDialogResult The user's response to the task dialog.
See Also