MEPSystemDivideSystem Method

Divide the phyisical networks in the system and create a new system for each network.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ICollection<ElementId> DivideSystem(
	Document ADoc
)

Parameters

ADoc  Document
The document.

Return Value

ICollectionElementId
The id of new created systems.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
InvalidOperationException The system is not dividable.
Remarks
This function only works for Hvac and Piping system.
See Also