LineLoadCreate(Document, ElementId, XYZ, XYZ, LineLoadType) Method |
Creates a new hosted line load within the project.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static LineLoad Create(
Document document,
ElementId hostElemId,
XYZ forceVector1,
XYZ momentVector1,
LineLoadType symbol
)
Public Shared Function Create (
document As Document,
hostElemId As ElementId,
forceVector1 As XYZ,
momentVector1 As XYZ,
symbol As LineLoadType
) As LineLoad
public:
static LineLoad^ Create(
Document^ document,
ElementId^ hostElemId,
XYZ^ forceVector1,
XYZ^ momentVector1,
LineLoadType^ symbol
)
static member Create :
document : Document *
hostElemId : ElementId *
forceVector1 : XYZ *
momentVector1 : XYZ *
symbol : LineLoadType -> LineLoad
Parameters
- document Document
-
Document to which new line load will be added.
- hostElemId ElementId
-
The analytical host element for the line Load.
- forceVector1 XYZ
-
The applied 3d force vector.
- momentVector1 XYZ
-
The applied 3d moment vector.
- symbol LineLoadType
-
The symbol of the LineLoad. Set to use default type.
Return Value
LineLoad
If successful, returns the newly created LineLoad,
otherwise.
Exceptions
See Also