EdgeIsFlippedOnFace(Face) Method

Determines if this edge's topological direction on the Face is opposite to its parametric direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool IsFlippedOnFace(
	Face face
)

Parameters

face  Face
The face with respect to which the direction is considered. Must belong to the edge.

Return Value

Boolean
true if this edge's topological direction on the Face is opposite to its parametric direction, false if the topological direction agrees with the parametric direction.
Exceptions
ExceptionCondition
ArgumentNullException Thrown when the specified face is .
ArgumentException Thrown when the specified face is not one of the faces for this edge.
Remarks
Outer edge loops on a Face are oriented counter-clockwise with respect to the Face's orientation, and inner loops are oriented clockwise. The topological direction of an edge on a face means the direction in which the edge's loop is being traversed.
See Also