ScheduleHeightsOnSheet Class

Heights information of a schedule on sheet.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBScheduleHeightsOnSheet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ScheduleHeightsOnSheet : IDisposable

The ScheduleHeightsOnSheet type exposes the following members.

Properties
 NameDescription
Public propertyColumnHeaderHeight The height of all schedule header part, including the gap line between header and body.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyTitleHeight The height of schedule title on sheet view.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the ScheduleHeightsOnSheet
Public methodGetBodyRowHeights Returns each row's height of schedule body on sheet view.
Top
Remarks
This class returns the heights of schedule title, column header and each body row on sheet view.
See Also