ScheduleHeightsOnSheet Class

Heights information of a schedule on sheet.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBScheduleHeightsOnSheet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ScheduleHeightsOnSheet : IDisposable

The ScheduleHeightsOnSheet type exposes the following members.

Properties
 NameDescription
Public propertyColumnHeaderHeight The height of all schedule header part, including the gap line between header and body.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyTitleHeight The height of schedule title on sheet view.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the ScheduleHeightsOnSheet
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetBodyRowHeights Returns each row's height of schedule body on sheet view.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
This class returns the heights of schedule title, column header and each body row on sheet view.
See Also