CompoundStructureSetMaterialId Method

Sets a material element for a specified layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetMaterialId(
	int layerIdx,
	ElementId materialId
)

Parameters

layerIdx  Int32
Index of a layer in the CompoundStructure.
materialId  ElementId
The ElementId of a Material element.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException The layer index is out of range.
Remarks
It is not verified that materialId corresponds to a valid Material element.
See Also