IExternalServiceGetServiceId Method |
Implement this method to return the unique Id of the service.
Namespace: Autodesk.Revit.DB.ExternalServiceAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
SyntaxExternalServiceId GetServiceId()
Function GetServiceId As ExternalServiceId
ExternalServiceId^ GetServiceId()
abstract GetServiceId : unit -> ExternalServiceId
Return Value
ExternalServiceId
The extensible enum value representing the Id of the service.
RemarksFor all built-in external services, their Ids are all items
of the enumerated type ExternalServices.BuiltInExternalServices.
Third-party services will have their respective Ids based on GUIDs.
It is important to note that a service Id must be unique. It will
be an error if two external services try to register with the same Id.
See Also