RebarShapeConstraintCircumference Class

A circumference constraint associated with an arc in a RebarShapeDefinition.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DB.StructureRebarShapeConstraint
    Autodesk.Revit.DB.StructureRebarShapeConstraintCircumference

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RebarShapeConstraintCircumference : RebarShapeConstraint

The RebarShapeConstraintCircumference type exposes the following members.

Constructors
 NameDescription
Public methodRebarShapeConstraintCircumference Create a circumference constraint.
Top
Properties
 NameDescription
Public propertyArcReferenceType The choice of rule for measuring the diameter.
Top
Methods
 NameDescription
Top
See Also