RebarShapeConstraintCircumference Class

A circumference constraint associated with an arc in a RebarShapeDefinition.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DB.StructureRebarShapeConstraint
    Autodesk.Revit.DB.StructureRebarShapeConstraintCircumference

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RebarShapeConstraintCircumference : RebarShapeConstraint

The RebarShapeConstraintCircumference type exposes the following members.

Constructors
 NameDescription
Public methodRebarShapeConstraintCircumference Create a circumference constraint.
Top
Properties
 NameDescription
Public propertyArcReferenceType The choice of rule for measuring the diameter.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from RebarShapeConstraint)
Top
Methods
 NameDescription
Public methodDispose
(Inherited from RebarShapeConstraint)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetParamId Return the Id of the parameter associated with this constraint.
(Inherited from RebarShapeConstraint)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also