DocumentNewFascia(FasciaType, ReferenceArray) Method |
Creates a fascia along a reference array.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic Fascia NewFascia(
FasciaType FasciaType,
ReferenceArray references
)
Public Function NewFascia (
FasciaType As FasciaType,
references As ReferenceArray
) As Fascia
public:
Fascia^ NewFascia(
FasciaType^ FasciaType,
ReferenceArray^ references
)
member NewFascia :
FasciaType : FasciaType *
references : ReferenceArray -> Fascia
Parameters
- FasciaType FasciaType
- The type of the fascia to create
- references ReferenceArray
- An array of planar lines and arcs that represents the place where you
want to place the fascia.
Return Value
Fascia If successful a new fascia object within the project, otherwise
.
ExceptionsException | Condition |
---|
ArgumentException | Thrown if the fascia type does not exist in the given document. |
See Also