DocumentGetDocumentVersion Method |
Gets the DocumentVersion that corresponds to a document.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static DocumentVersion GetDocumentVersion(
Document doc
)
Public Shared Function GetDocumentVersion (
doc As Document
) As DocumentVersion
public:
static DocumentVersion^ GetDocumentVersion(
Document^ doc
)
static member GetDocumentVersion :
doc : Document -> DocumentVersion
Parameters
- doc Document
-
The document whose DocumentVersion will be returned.
Return Value
DocumentVersion
The DocumentVersion corresponding to the given document.
Exceptions
Remarks
This function can be combined with
IsModified
to see whether a document in memory is different from a version on disk. The documents
are different if the document is modified or if the two DocumentVersions differ.
See Also