StructuralConnectionTypeValidFamilySymbolId Method

Checks whether the family symbol id is allowed for StructuralConnectionTypes with the given value for the applyTo property.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool ValidFamilySymbolId(
	Document doc,
	StructuralConnectionApplyTo applyTo,
	ElementId familySymbolId
)

Parameters

doc  Document
 
applyTo  StructuralConnectionApplyTo
 
familySymbolId  ElementId
 

Return Value

Boolean
True if %familySymbolId% is invalidElementId; or if it is the id of a FamilySymbol of category "Connection Symbols" (OST_StructConnectionSymbols) with its "Apply To" parameter set to match the applyTo property. Returns false otherwise.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also