TableSectionDataSetCellParamIdAndCategoryId(Int32, ElementId, ElementId) Method

Sets a column's category and parameter Id

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetCellParamIdAndCategoryId(
	int nCol,
	ElementId paramId,
	ElementId categoryId
)

Parameters

nCol  Int32
 
paramId  ElementId
 
categoryId  ElementId
 
Exceptions
ExceptionCondition
ArgumentException The given column number nCol is invalid. -or- The paramId or categoryId is not acceptable.
ArgumentNullException A non-optional argument was null
InvalidOperationException This operation is forbidden for cells in standard schedule body sections.
See Also