TessellatedShapeBuilderCreateMeshByExtrusion Method |
Builds a mesh by extruding curve loop(s) along extrusion distance.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static MeshFromGeometryOperationResult CreateMeshByExtrusion(
IList<CurveLoop> profileLoops,
XYZ extrusionDirection,
double extrusionDistance,
ElementId materialId
)
Public Shared Function CreateMeshByExtrusion (
profileLoops As IList(Of CurveLoop),
extrusionDirection As XYZ,
extrusionDistance As Double,
materialId As ElementId
) As MeshFromGeometryOperationResult
public:
static MeshFromGeometryOperationResult^ CreateMeshByExtrusion(
IList<CurveLoop^>^ profileLoops,
XYZ^ extrusionDirection,
double extrusionDistance,
ElementId^ materialId
)
static member CreateMeshByExtrusion :
profileLoops : IList<CurveLoop> *
extrusionDirection : XYZ *
extrusionDistance : float *
materialId : ElementId -> MeshFromGeometryOperationResult
Parameters
- profileLoops IListCurveLoop
-
The profile loops to be extruded. The loops will not be modified.
- extrusionDirection XYZ
-
Direction of extrusion. The length of this vector is ignored.
- extrusionDistance Double
-
The positive distance by which the loops are extruded in the
direction of the input extrusionDir.
- materialId ElementId
-
Material which should be used by a constructed mesh.
Return Value
MeshFromGeometryOperationResult
Returns a mesh, which was constructed, and some additional
information.
Exceptions
Remarks
This function supports creation of a mesh given a collection
of continuous curve loops, which are processed independently
from each other. Loops with gaps or with curves with
wrong flips will be split before processing.
See Also