AreaBasedLoadDataConnectToUpstreamNode Method |
Connects to an upstream electrical analytical node.
Namespace: Autodesk.Revit.DB.ElectricalAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void ConnectToUpstreamNode(
ElementId upstreamNodeId
)
Public Sub ConnectToUpstreamNode (
upstreamNodeId As ElementId
)
public:
void ConnectToUpstreamNode(
ElementId^ upstreamNodeId
)
member ConnectToUpstreamNode :
upstreamNodeId : ElementId -> unit
Parameters
- upstreamNodeId ElementId
-
The upstream electrical analytical node id.
ExceptionsException | Condition |
---|
ArgumentException |
The id is not an electrical analytical node id.
-or-
The area based load can not connect to the upstream electrical analytical node.
|
ArgumentNullException |
A non-optional argument was null
|
Remarks
If the area based load supplies from Node A, Node A is the upstream node of the area based load, and the area based load is the downstream node of node A.
See Also