FilteredWorksetCollectorWherePasses Method |
Applies a workset filter to the collector.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic FilteredWorksetCollector WherePasses(
WorksetFilter filter
)
Public Function WherePasses (
filter As WorksetFilter
) As FilteredWorksetCollector
public:
FilteredWorksetCollector^ WherePasses(
WorksetFilter^ filter
)
member WherePasses :
filter : WorksetFilter -> FilteredWorksetCollector
Parameters
- filter WorksetFilter
-
The workset filter.
Return Value
FilteredWorksetCollector
A handle to this collector. This is the same collector that has just been modified, returned
so you can chain multiple calls together in one line.
Exceptions
Remarks
The filter will be added as an additional condition that all filtered worksets must pass.
If you have an active iterator to this collector it will be stopped by this call.
See Also