MEPSectionGetSegmentLength Method |
Get the length for the specified segment id in this section.
Namespace: Autodesk.Revit.DB.MechanicalAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic double GetSegmentLength(
ElementId segmentId
)
Public Function GetSegmentLength (
segmentId As ElementId
) As Double
public:
double GetSegmentLength(
ElementId^ segmentId
)
member GetSegmentLength :
segmentId : ElementId -> float
Parameters
- segmentId ElementId
-
The element id which can be duct segment and pipe segment.
Return Value
Double
Exceptions
See Also