ViewGetFilterVisibility Method |
Gets the visibility of the elements associated with a filter.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool GetFilterVisibility(
ElementId filterElementId
)
Public Function GetFilterVisibility (
filterElementId As ElementId
) As Boolean
public:
bool GetFilterVisibility(
ElementId^ filterElementId
)
member GetFilterVisibility :
filterElementId : ElementId -> bool
Parameters
- filterElementId ElementId
-
The ElementId of the filter.
Return Value
Boolean
True if the elements associated with the filter are visible in the view, false otherwise.
ExceptionsException | Condition |
---|
ArgumentException |
Filter is not applied to the view.
-or-
ElementId is not associated with a FilterElement.
|
ArgumentNullException |
A non-optional argument was null
|
InvalidOperationException |
The element "this View" does not belong to a project document.
-or-
The view type does not support Visibility/Graphics Overriddes.
|
See Also