ColumnAttachmentGetColumnAttachment(FamilyInstance, ElementId) Method |
Look up a column attachment by specifying the target id.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static ColumnAttachment GetColumnAttachment(
FamilyInstance column,
ElementId targetId
)
Public Shared Function GetColumnAttachment (
column As FamilyInstance,
targetId As ElementId
) As ColumnAttachment
public:
static ColumnAttachment^ GetColumnAttachment(
FamilyInstance^ column,
ElementId^ targetId
)
static member GetColumnAttachment :
column : FamilyInstance *
targetId : ElementId -> ColumnAttachment
Parameters
- column FamilyInstance
-
A column.
- targetId ElementId
-
Id of a target element.
Return Value
ColumnAttachment
The column attachment attaching the column to the target, or
if there
is no such attachment.
Exceptions
Remarks
May return either a top or base attachment.
See Also