RebarShapeDefinitionBySegmentsSetSegmentAs180DegreeBend(Int32, ElementId, Boolean) Method |
Indicate that a segment is a "virtual" segment introduced to describe a 180-degree bend. The radius of the bend will be driven by radiusParam.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetSegmentAs180DegreeBend(
int iSegment,
ElementId paramId,
bool measureToOutsideOfBend
)
Public Sub SetSegmentAs180DegreeBend (
iSegment As Integer,
paramId As ElementId,
measureToOutsideOfBend As Boolean
)
public:
void SetSegmentAs180DegreeBend(
int iSegment,
ElementId^ paramId,
bool measureToOutsideOfBend
)
member SetSegmentAs180DegreeBend :
iSegment : int *
paramId : ElementId *
measureToOutsideOfBend : bool -> unit
Parameters
- iSegment Int32
-
Index of the segment (0 to NumberOfSegments - 1).
- paramId ElementId
-
Id of a parameter to drive the radius.
To obtain the id of a shared parameter,
call RebarShape.GetElementIdForExternalDefinition().
- measureToOutsideOfBend Boolean
-
Choose between two possibilities for the references of the radius dimension.
If true, measure to the exterior face of the bar. If false, measure to the interior face.
ExceptionsException | Condition |
---|
ArgumentException |
iSegment is not between 0 and NumberOfSegments.
-or-
paramId is not the id of a shared parameter in the current document,
or its unit type is not UT_Reinforcement_Length or UT_Angle.
|
ArgumentNullException |
A non-optional argument was null
|
See Also