ParameterFilterElementGetElementFilterParameters Method |
Retrieves a list of the parameters associated with each rule in the filter.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ISet<ElementId> GetElementFilterParameters()
Public Function GetElementFilterParameters As ISet(Of ElementId)
public:
ISet<ElementId^>^ GetElementFilterParameters()
member GetElementFilterParameters : unit -> ISet<ElementId>
Return Value
ISetElementId
A set of parameter identifiers.
Remarks
This function returns only parameters used by this ParameterFilterElement that are common
to all categories specified in this ParameterFilterElement.
The ElementFilter may also contain parameters specific to one of the categories
and not necessarily common to all categories specified in this ParameterFilterElement.
To get those parameters, use ParameterFilterElement.GetElementFilterParametersForCategory().
See Also