TableSectionDataSetCellFormatOptions Method |
Sets a cell's FormatOptions.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetCellFormatOptions(
int nRow,
int nCol,
FormatOptions options
)
Public Sub SetCellFormatOptions (
nRow As Integer,
nCol As Integer,
options As FormatOptions
)
public:
void SetCellFormatOptions(
int nRow,
int nCol,
FormatOptions^ options
)
member SetCellFormatOptions :
nRow : int *
nCol : int *
options : FormatOptions -> unit
Parameters
- nRow Int32
-
The row index of the cell
- nCol Int32
-
The column index of the cell
- options FormatOptions
-
The format option to assign
ExceptionsException | Condition |
---|
ArgumentException |
The given row number nRow is invalid.
-or-
The given column number nCol is invalid.
-or-
The display unit in options is not a valid display unit for the unit type of the cell, or the rounding method in options is not set to Nearest. See UnitUtils.IsValidDisplayUnit(UnitType, DisplayUnitType), UnitUtils.GetValidDisplayUnits(UnitType) and FormatOptions.RoundingMethod.
|
ArgumentNullException |
A non-optional argument was null
|
See Also