IExportContextBaseOnPolyline Method |
This method is called when a Polyline is being output.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
SyntaxRenderNodeAction OnPolyline(
PolylineNode node
)
Function OnPolyline (
node As PolylineNode
) As RenderNodeAction
RenderNodeAction OnPolyline(
PolylineNode^ node
)
abstract OnPolyline :
node : PolylineNode -> RenderNodeAction
Parameters
- node PolylineNode
-
An output node that represents a Polyline.
Return Value
RenderNodeAction
Return RenderNodeAction.Proceed if you wish to receive tessellated geometry
(polyline segments) for this polyline, or otherwise return RenderNodeAction.Skip.
Note for 2D export: if the export is performed for the view in non-Wireframe display style
tesselated geometry will be output regardless of the return value.
Remarks
Note that this method is invoked only if the custom exporter
was set up to include geometric objects in the output stream.
See
IncludeGeometricObjects for mode details.
Note for 2D export: if the export is performed for the view in non-Wireframe display style
this method will be called regardless of whether the object will be eventially output,
i.e. even if it's occluded by another element.
See Also