RenderingQualitySettingsLightAndMaterialAccuracyMode Property |
A value that controls light and material accuracy mode.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic LightAndMaterialAccuracyMode LightAndMaterialAccuracyMode { get; set; }
Public Property LightAndMaterialAccuracyMode As LightAndMaterialAccuracyMode
Get
Set
public:
property LightAndMaterialAccuracyMode LightAndMaterialAccuracyMode {
LightAndMaterialAccuracyMode get ();
void set (LightAndMaterialAccuracyMode value);
}
member LightAndMaterialAccuracyMode : LightAndMaterialAccuracyMode with get, set
Property Value
LightAndMaterialAccuracyMode
ExceptionsException | Condition |
---|
ArgumentOutOfRangeException |
When setting this property: A value passed for an enumeration argument is not a member of that enumeration
|
InvalidOperationException |
When setting this property: The RenderingQualitySettings does not use custom quality currently.
To use custom quality, set RenderingQuality property to RenderingQuality.Custom.
|
Remarks
The method of the renderer engine dealing with materials and shadows.
See Also