LightAndMaterialAccuracyMode Enumeration |
An enumerated type containing possible Light and Material Accuracy modes for Raytracer render.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum LightAndMaterialAccuracyMode
Public Enumeration LightAndMaterialAccuracyMode
public enum class LightAndMaterialAccuracyMode
type LightAndMaterialAccuracyMode
MembersMember name | Value | Description |
---|
Simplified | 1 |
Rough and semi-rough materials are approximated. Consequently, materials may look more shinier than expected.
Lighting is approximated so shadows will lack in details.
|
Advanced | 2 |
Soft shadows and soft reflections from semi-rough materials will be rendered with a high quality level. This is the
standard setting that you typically want to rely on for final high quality renderings.
|
See Also