BalusterPatternDuplicateBaluster Method

Duplicates the baluster pointed by given index in the main baluster pattern.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public BalusterInfo DuplicateBaluster(
	int index
)

Parameters

index  Int32
Baluster index.

Return Value

BalusterInfo
The duplicated baluster.
Exceptions
ExceptionCondition
ArgumentOutOfRangeException The index index is out of range.
Remarks
The new baluster will be inserted just after the source baluster.
See Also