LoadCaseCreate(Document, String, ElementId, ElementId) Method

Creates a new LoadCase.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static LoadCase Create(
	Document document,
	string name,
	ElementId natureId,
	ElementId subcategoryId
)

Parameters

document  Document
The Document to which new load case element will be added.
name  String
The name of the load case.
natureId  ElementId
The load nature ID.
subcategoryId  ElementId
The load case subcategory ID. Could be one of predefined or user defined load case category. Built-in structural Load Cases (OST_LoadCases) subcategories are: OST_LoadCasesDeadOST_LoadCasesLiveOST_LoadCasesWindOST_LoadCasesSnowOST_LoadCasesRoofLiveOST_LoadCasesAccidentalOST_LoadCasesTemperatureOST_LoadCasesSeismic

Return Value

LoadCase
The newly created load case element if successful, otherwise.
Exceptions
ExceptionCondition
ArgumentException The given name is not unique.
ArgumentNullException A non-optional argument was null
Remarks
This method is designed to create LoadCase that is associated with user defined category.
See Also