AnalyticalToPhysicalAssociationManagerAddAssociation(ISetElementId, ISetElementId) Method |
Adds a new association between a group of analytical elements and a group of physical elements.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void AddAssociation(
ISet<ElementId> analyticalElementIds,
ISet<ElementId> physicalElementIds
)
Public Sub AddAssociation (
analyticalElementIds As ISet(Of ElementId),
physicalElementIds As ISet(Of ElementId)
)
public:
void AddAssociation(
ISet<ElementId^>^ analyticalElementIds,
ISet<ElementId^>^ physicalElementIds
)
member AddAssociation :
analyticalElementIds : ISet<ElementId> *
physicalElementIds : ISet<ElementId> -> unit
Parameters
- analyticalElementIds ISetElementId
-
Ids of the analytical elements.
- physicalElementIds ISetElementId
-
Ids of the physical elements.
ExceptionsException | Condition |
---|
ArgumentException |
Analytical id is not valid or has already defined another association.
-or-
Physical id is not valid or has already defined another association.
|
ArgumentNullException |
A non-optional argument was null
|
Remarks
The arguments must be ids of analytical and of physical elements that don't have other associations, otherwise an exception is thrown.
Physical elements can have one of these categories:
- Columns
- Curtain Wall Panels
- Floors
- Generic Models
- Mass
- Parts
- Railings
- Ramps
- Roofs
- Stairs
- Structural Columns
- Structural Foundation
- Structural Framing
- Structural Trusses
- Structural Beam System
- Walls
Analytical elements can have one of these categories:
- Analytical Member
- Analytical Panel
See Also