ConnectorManager Class

Provides access to the Connector Manager
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBConnectorManager

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ConnectorManager : IDisposable

The ConnectorManager type exposes the following members.

Properties
 NameDescription
Public propertyConnectorsReturn all the Connectors of the Connector Manager.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyOwner This property is used to retrieve the owner of the Connector Manager.
Public propertyUnusedConnectorsReturn all the unused Connectors of the Connector Manager.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the ConnectorManager
Public methodLookup Lookup the connector using the unique index value that identify this connector.
Top
See Also