BalusterInfoBaseReferenceName Property

Represents the name of the reference for the bottom of this baluster or post.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public string BaseReferenceName { get; set; }

Property Value

String
Exceptions
ExceptionCondition
ArgumentException When setting this property: The name doesn't refer to a valid reference.
ArgumentNullException When setting this property: A non-optional argument was null
Remarks
Two pre-defined reference names can be obtained using [!:Autodesk::Revit::DB::Architecture::BalusterInfo::getReferenceNameForHost()] or [!:Autodesk::Revit::DB::Architecture::BalusterInfo::getReferenceNameForTopRail()]. The rest of valid reference names that are allowed to be used in the setter for BaseReferenceName are the actual names of non-continuous rails [!:Autodesk::Revit::DB::Architecture::NonContinuousRailInfo::Name] in [!:Autodesk::Revit::DB::Architecture::NonContinuousRailStructure]
See Also