Creates a new Viewport at a given location on a sheet.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static Viewport Create(
Document document,
ElementId viewSheetId,
ElementId viewId,
XYZ point
)
Public Shared Function Create (
document As Document,
viewSheetId As ElementId,
viewId As ElementId,
point As XYZ
) As Viewport
public:
static Viewport^ Create(
Document^ document,
ElementId^ viewSheetId,
ElementId^ viewId,
XYZ^ point
)
static member Create :
document : Document *
viewSheetId : ElementId *
viewId : ElementId *
point : XYZ -> Viewport
Parameters
- document Document
-
The document to which the new Viewport will be added.
- viewSheetId ElementId
-
The ViewSheet on which the new Viewport will be placed.
- viewId ElementId
-
The view shown in the Viewport.
- point XYZ
-
The new Viewport will be centered on this point.
Return Value
Viewport
The new Viewport.
Exceptions
Remarks
Use [!:Autodesk::Revit::DB::ScheduleSheetInstance::Create()] to add schedules to sheets.
See Also