FilledRegionCreateMaskingRegion(Document, ElementId, IListCurveLoop) Method |
Creates a view-specific masking region from the given boundaries.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static FilledRegion CreateMaskingRegion(
Document document,
ElementId viewId,
IList<CurveLoop> boundaries
)
Public Shared Function CreateMaskingRegion (
document As Document,
viewId As ElementId,
boundaries As IList(Of CurveLoop)
) As FilledRegion
public:
static FilledRegion^ CreateMaskingRegion(
Document^ document,
ElementId^ viewId,
IList<CurveLoop^>^ boundaries
)
static member CreateMaskingRegion :
document : Document *
viewId : ElementId *
boundaries : IList<CurveLoop> -> FilledRegion
Parameters
- document Document
-
The document in which to create the masking region.
- viewId ElementId
-
The view Id.
- boundaries IListCurveLoop
-
The boundaries.
Return Value
FilledRegion
The newly created masking region.
ExceptionsException | Condition |
---|
ArgumentException |
The document is a 3d model family.
-or-
Details can't be drawn in the view.
-or-
Masking regions and Filled regions can't be created in this document or view.
-or-
The input curve loops cannot compose a valid boundary, that means:
the "curveLoops" collection is empty;
or some curve loops intersect with each other;
or each curve loop is not closed individually;
or each curve loop is not planar;
or each curve loop is not in a plane parallel to the view's detail sketch plane;
or input curves contain at least one helical curve.
-or-
Thrown if the viewId is invalid, or the view does not support
the detail items creation, or if the boundaries are empty, open, or self-intersecting.
|
ArgumentNullException |
A non-optional argument was null
|
Remarks
View-specific masking regions can be created in models and 2d families.
The line style of the boundaries will be set to thin lines by default.
See Also