PathReinforcementIsValidRebarShapeId Method |
Identifies whether an element id corresponds to a Rebar Shape element which can be used in Path Reinforcement.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool IsValidRebarShapeId(
Document aDoc,
ElementId elementId
)
Public Shared Function IsValidRebarShapeId (
aDoc As Document,
elementId As ElementId
) As Boolean
public:
static bool IsValidRebarShapeId(
Document^ aDoc,
ElementId^ elementId
)
static member IsValidRebarShapeId :
aDoc : Document *
elementId : ElementId -> bool
Parameters
- aDoc Document
-
The document.
- elementId ElementId
-
An element id.
Return Value
Boolean
True if the specified element id corresponds to a Rebar Shape element.
Exceptions
Remarks
The Rebar Shape has to be two dimensional shape only
and its neighbouring segments may form only right angles.
See Also