ApplicationIsValidThickness Method |
Checks if the input value is valid to be supplied as a thickness (for an extrusion, or blend, or wall layer, or similar geometric construct).
Namespace: Autodesk.Revit.ApplicationServicesAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool IsValidThickness(
double thickness
)
Public Shared Function IsValidThickness (
thickness As Double
) As Boolean
public:
static bool IsValidThickness(
double thickness
)
static member IsValidThickness :
thickness : float -> bool
Parameters
- thickness Double
-
The input value.
Return Value
Boolean
True if the input value is valid for thickness; false otherwise.
Remarks
This checks two conditions:
- The value is greater than or equal to the minimum thickness allowed in Revit for these types of geometric constructs.
- The value is less than or equal to the maximum length/distance allowed by Revit for elements.
See Also