DocumentNewRoom(Phase) Method |
Creates a new unplaced room and with an assigned phase.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic Room NewRoom(
Phase phase
)
Public Function NewRoom (
phase As Phase
) As Room
public:
Room^ NewRoom(
Phase^ phase
)
member NewRoom :
phase : Phase -> Room
Parameters
- phase Phase
- The phase in which the room is to exist.
Return Value
Room If successful the new room , otherwise
.
ExceptionsException | Condition |
---|
ArgumentException | Thrown if the phase does not exist in the given document. |
See Also