ConnectorElementCreatePipeConnector(Document, PipeSystemType, Reference, Edge) Method |
Create a new pipe ConnectorElement with a face and an edge.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static ConnectorElement CreatePipeConnector(
Document document,
PipeSystemType pipeSystemType,
Reference planarFace,
Edge edge
)
Public Shared Function CreatePipeConnector (
document As Document,
pipeSystemType As PipeSystemType,
planarFace As Reference,
edge As Edge
) As ConnectorElement
public:
static ConnectorElement^ CreatePipeConnector(
Document^ document,
PipeSystemType pipeSystemType,
Reference^ planarFace,
Edge^ edge
)
static member CreatePipeConnector :
document : Document *
pipeSystemType : PipeSystemType *
planarFace : Reference *
edge : Edge -> ConnectorElement
Parameters
- document Document
-
The document to add the connector to.
- pipeSystemType PipeSystemType
-
The PipeSystemType of the connector.
- planarFace Reference
-
The planar face to place the connector on.
- edge Edge
-
One of the edges in the edge loop that defines the connector location on the planar face.
Return Value
ConnectorElement
The pipe ConnectorElement.
Exceptions
Remarks
Regenerates the document.
See Also