PipeSystemType Enumeration |
An enumerated type listing all the possible pipe system types for a connector object.
Namespace: Autodesk.Revit.DB.PlumbingAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum PipeSystemType
Public Enumeration PipeSystemType
public enum class PipeSystemType
MembersMember name | Value | Description |
---|
UndefinedSystemType | 0 |
Pipe System Type is UndefinedSystemClassification.
|
SupplyHydronic | 7 |
Pipe System Type is SupplyHydronic.
|
ReturnHydronic | 8 |
Pipe System Type is ReturnHydronic.
|
Sanitary | 16 |
Pipe System Type is Sanitary.
|
Vent | 17 |
Pipe System Type is Vent.
|
DomesticHotWater | 19 |
Pipe System Type is DomesticHotWater.
|
DomesticColdWater | 20 |
Pipe System Type is DomesticColdWater.
|
OtherPipe | 22 |
Pipe System Type is OtherPipe.
|
FireProtectWet | 23 |
Pipe System Type is FireProtectWet.
|
FireProtectDry | 24 |
Pipe System Type is FireProtectDry.
|
FireProtectPreaction | 25 |
Pipe System Type is FireProtectPreaction.
|
FireProtectOther | 26 |
Pipe System Type is FireProtectOther.
|
Fitting | 28 |
Pipe System Type is Fitting.
|
Global | 29 |
Pipe System Type is Global.
|
See Also