PartMakerSetSourceElementIds Method |
Set the source elements for the PartMaker.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetSourceElementIds(
ICollection<ElementId> sourceElementIds
)
Public Sub SetSourceElementIds (
sourceElementIds As ICollection(Of ElementId)
)
public:
void SetSourceElementIds(
ICollection<ElementId^>^ sourceElementIds
)
member SetSourceElementIds :
sourceElementIds : ICollection<ElementId> -> unit
Parameters
- sourceElementIds ICollectionElementId
-
Elements to be the sources for this PartMaker.
ExceptionsException | Condition |
---|
ArgumentException |
One or more element ids was not permitted to be a source for this PartMaker
Elements should be Parts that have no PartMaker yet
|
ArgumentNullException |
A non-optional argument was null
|
See Also