RebarShapeDefinitionBySegmentsAddBendVariableRadius Method |
Specify a variable-radius bend.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void AddBendVariableRadius(
int vertexIndex,
RebarShapeVertexTurn turn,
RebarShapeBendAngle angle,
ElementId paramId,
bool measureIncludingBarThickness
)
Public Sub AddBendVariableRadius (
vertexIndex As Integer,
turn As RebarShapeVertexTurn,
angle As RebarShapeBendAngle,
paramId As ElementId,
measureIncludingBarThickness As Boolean
)
public:
void AddBendVariableRadius(
int vertexIndex,
RebarShapeVertexTurn turn,
RebarShapeBendAngle angle,
ElementId^ paramId,
bool measureIncludingBarThickness
)
member AddBendVariableRadius :
vertexIndex : int *
turn : RebarShapeVertexTurn *
angle : RebarShapeBendAngle *
paramId : ElementId *
measureIncludingBarThickness : bool -> unit
Parameters
- vertexIndex Int32
-
Index of the vertex (1 to NumberOfVertices - 2).
- turn RebarShapeVertexTurn
-
Specify turn direction (RebarShapeVertexTurn::Left or RebarShapeVertexTurn::Right).
- angle RebarShapeBendAngle
-
Specify whether the bend is acute, obtuse, etc.
- paramId ElementId
-
Id of a parameter driving the radius.
- measureIncludingBarThickness Boolean
-
If true, the radius is measured to the outside of the
bend; if false, it is measured to the inside.
ExceptionsException | Condition |
---|
ArgumentException |
vertexIndex is not between 0 and NumberOfVertices.
-or-
paramId is not the id of a shared parameter in the current document,
or its unit type is not UT_Reinforcement_Length or UT_Angle.
|
ArgumentNullException |
A non-optional argument was null
|
ArgumentOutOfRangeException |
A value passed for an enumeration argument is not a member of that enumeration
|
Remarks
You must add a bend between each two segments.
See Also