LabelUtilsGetLabelForDiscipline Method

Gets the user-visible name for a discipline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static string GetLabelForDiscipline(
	ForgeTypeId disciplineTypeId
)

Parameters

disciplineTypeId  ForgeTypeId
Identifier of the discipline.

Return Value

String
Exceptions
ExceptionCondition
ArgumentException Discipline must have a definition.
ArgumentNullException A non-optional argument was null
Remarks
The name is obtained in the current Revit language.
See Also