WorksharingUtilsRelinquishOwnership Method

Relinquishes ownership by the current user of as many specified elements and worksets as possible, and grants element ownership requested by other users on a first-come, first-served basis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static RelinquishedItems RelinquishOwnership(
	Document document,
	RelinquishOptions generalCategories,
	TransactWithCentralOptions options
)

Parameters

document  Document
The document containing the elements and worksets.
generalCategories  RelinquishOptions
General categories of items to relinquish. See RelinquishOptions for details.
options  TransactWithCentralOptions
Options to customize access to the central model. is allowed and means no customization.

Return Value

RelinquishedItems
The elements and worksets that were relinquished.
Exceptions
ExceptionCondition
ArgumentException document is not a workshared document. -or- document is not a primary document, it is a linked document. -or- document is read-only: It cannot be modified. -or- document has an open editing transaction and is accepting changes. -or- Saving is not allowed in the current application mode.
ArgumentNullException A non-optional argument was null
CentralFileCommunicationException The file-based central model could not be reached, e.g. the network is down or the file server is down.
CentralModelAccessDeniedException Access to the central model was denied due to lack of access privileges. -or- Access to the central model was denied. A possible reason is because the model was under maintenance.
CentralModelContentionException The central model is locked by another client.
CentralModelException The central model is overwritten by other user. -or- The central model is missing. -or- An internal error happened on the central model, please contact the server administrator.
InvalidOperationException Operation is not permitted when there is any open sub-transaction, transaction, or transaction group.
RevitServerCommunicationException The server-based central model could not be accessed because of a network communication error.
RevitServerInternalException An internal error happened on the server, please contact the server administrator.
Remarks

Elements and worksets owned by other users are ignored.

Only unmodified elements already in central will be relinquished by this method. Newly added and modified elements cannot be relinquished until they have been synchronized with central.

For best performance, relinquish items in one big call, rather than many small calls.

See Also