FilterStringBeginsWith Class

Tests whether string values from the document begin with a certain string.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBFilterStringRuleEvaluator
    Autodesk.Revit.DBFilterStringBeginsWith

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FilterStringBeginsWith : FilterStringRuleEvaluator

The FilterStringBeginsWith type exposes the following members.

Constructors
 NameDescription
Public methodFilterStringBeginsWith Constructs an instance of FilterStringBeginsWith.
Top
Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from FilterStringRuleEvaluator)
Top
Methods
 NameDescription
Public methodDispose
(Inherited from FilterStringRuleEvaluator)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodEvaluate Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not.
(Inherited from FilterStringRuleEvaluator)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
All string comparisons in this class are performed in the case-insensitive manner.
See Also