FilterStringRuleEvaluatorEvaluate Method |
Derived classes override this method to implement the test that determines
whether the two given string values satisfy the desired condition or not.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool Evaluate(
string lhs,
string rhs,
bool caseSensitive
)
Public Function Evaluate (
lhs As String,
rhs As String,
caseSensitive As Boolean
) As Boolean
public:
bool Evaluate(
String^ lhs,
String^ rhs,
bool caseSensitive
)
member Evaluate :
lhs : string *
rhs : string *
caseSensitive : bool -> bool
Parameters
- lhs String
-
A value from an element in the document.
- rhs String
-
The user-supplied value against which values from the document are tested.
- caseSensitive Boolean
-
If true, string comparisons are done case-sensitively.
Return Value
Boolean
True if the given arguments satisfy the condition, otherwise false.
Exceptions
Remarks
The arguments may be thought of as the left and right operands of a
binary expression; for example, "a < b", "x >= 100", etc. The left
operand comes from an element in the Revit document (e.g., the value
of a parameter.) The right operand is supplied by the user when
creating the filter that contains the rule that uses this evaluator.
See Also