Describes the visibility of a particular geometry object.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
SyntaxPublic Enumeration Visibility
public enum class Visibility
MembersMember name | Value | Description |
---|
Visible | 0 | The geometry object is always visible. This type of geometry is always returned by
GeometryOptions |
Highlight | 1 | The geometry object is visible, but is affected by highlight or prehighlight special coloration.
This type of geometry is returned by GeometryOptions
if IncludeNonVisibleObjects is true. |
Contextual | 2 | The geometry object is visible in some contexts, but not in others. This type of geometry is always returned by
GeometryOptions,
even when Revit is in a context where the geometry should not be visible, but only if
IncludeNonVisibleObjects is true.
Examples of geometry of this class include Solids representing insulation and lining for MEP ducts and pipes. |
Invisible | 3 | The geometry object is never visible. This type of geometry is never returned by
GeometryOptions but may be obtained by other
API operations. |
See Also