DocumentNewFlexDuct(Connector, Connector, FlexDuctType) Method |
Adds a new flexible duct into the document,
using two connector, and duct type.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic FlexDuct NewFlexDuct(
Connector connector1,
Connector connector2,
FlexDuctType ductType
)
Public Function NewFlexDuct (
connector1 As Connector,
connector2 As Connector,
ductType As FlexDuctType
) As FlexDuct
public:
FlexDuct^ NewFlexDuct(
Connector^ connector1,
Connector^ connector2,
FlexDuctType^ ductType
)
member NewFlexDuct :
connector1 : Connector *
connector2 : Connector *
ductType : FlexDuctType -> FlexDuct
Parameters
- connector1 Connector
- The first connector to be connected to the duct.
- connector2 Connector
- The second connector to be connected to the duct.
- ductType FlexDuctType
- The type of the flexible duct.
Return Value
FlexDuct If creation was successful then a new flexible duct is returned,
otherwise an exception with failure information will be thrown.
Exceptions
RemarksIf the connectors are fitting or equipment connectors of the correct domain,
and if the connectors' direction match the direction of the flexible duct to be created,
the connectors will be automatically connected. A transition fitting will be added
at the connector(s) if necessary. If the connector's type, domain,
does not match the one of the input connector, no connection will be established.
See Also